summaryrefslogtreecommitdiff
path: root/net-misc/zerotier/files/zerotier-1.14.0-respect-ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/zerotier/files/zerotier-1.14.0-respect-ldflags.patch')
-rw-r--r--net-misc/zerotier/files/zerotier-1.14.0-respect-ldflags.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-misc/zerotier/files/zerotier-1.14.0-respect-ldflags.patch b/net-misc/zerotier/files/zerotier-1.14.0-respect-ldflags.patch
new file mode 100644
index 000000000000..12e00b598975
--- /dev/null
+++ b/net-misc/zerotier/files/zerotier-1.14.0-respect-ldflags.patch
@@ -0,0 +1,24 @@
+https://github.com/zerotier/ZeroTierOne/pull/2162
+
+From 55485ad51e5de6a344f7dc7f352df1876fa747ea Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Sun, 29 Oct 2023 14:11:13 +0200
+Subject: [PATCH 1/2] Respect user LDFLAGS
+
+* Respect user LDFLAGS instead of replacing them.
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/make-linux.mk
++++ b/make-linux.mk
+@@ -71,7 +71,7 @@ else
+ override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
+ CXXFLAGS?=-O3 -fstack-protector
+ override CXXFLAGS+=-Wall -Wno-deprecated -std=c++17 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
+- LDFLAGS=-pie -Wl,-z,relro,-z,now
++ LDFLAGS?=-pie -Wl,-z,relro,-z,now
+ ZT_CARGO_FLAGS=--release
+ endif
+
+--
+2.45.1
+