summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.03.10.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 37b56c7ad0cc..da6df9eb14de 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,4 +1,6 @@
DIST yt-dlp-2023.12.30.tar.gz 5402838 BLAKE2B b2cdba23d426f862b8fc7a09002abfa8a6c27a1f1bded987d0b4b412266856d2d0f62dd2bc9cf3e34c671f01539252fc19587dec9a417b2e8f56370ef0f5c610 SHA512 23062e61cae9c51436f16de0a5ee0b351e59554ab4b5b90bed819d98b6b677bfd1797abae5baf52964eb64236c4b7abe23e37ca88ed10cbce3f7356081be59c4
+DIST yt-dlp-2024.03.10.tar.gz 5515436 BLAKE2B ce25d2ce78ebd107deab12a117ac9efa634052264d780c62531226c7128b1ba5ca52c952dc85dcefe137aadf08cffa417a135b996f864315866c35fd7209ec6b SHA512 6bfe1aeab98f559a2b23ffa12b63b40974312709039313695f41c7beb16d29f21953c61ab633d567e42deeec72fb0932950ddeb4b821fffb93fbae9ae0cb30a2
EBUILD yt-dlp-2023.12.30.ebuild 2168 BLAKE2B 1ac19ca26722c3abf9b9179c0e14037301340b506a04ef6ba96fce3ce61f62e6b84e4163e8c77bf20def4e956e839dd8af566aa9f5e73bdc70d015a6296ed1ee SHA512 ac4c4aec675b2a3a326c0a236c20edf637f4fbad4c3944a8c0b57617663f3ea667bde5f43153df02b36aaf618c9fc9584b5810603d49639b4891195654a98c91
+EBUILD yt-dlp-2024.03.10.ebuild 2163 BLAKE2B c4e12c2a1bd3f17f9166c1211197b05cf90806761b7835be4ca0acd29133e8828f4ef7c40973c83f6136eaea3d982abdae15e476e62656e29b2c59719262efaa SHA512 94ea29a669760093ce2af9c57bd0fe0bce8675851add306387b34d5de73c380609b0d24c1017ae17b5aead9856f3f55b5c9d4de5c4f33515c16925ad56bd647a
EBUILD yt-dlp-9999.ebuild 2324 BLAKE2B cca02c1fd8110c080fd2b2a511aa440ba5f1c6283981bff9e62954d4f38bac7fa6d2747a23733fe6d929aa1a31ab208e7c406754c60f88425c2a65d1c63f6a50 SHA512 3c56bb1ccac95fa9f542b97c92d35df981e4719a3912f126936ce56d2cd54554bba7a528d86d456279fbcd9dbd384f563e130fae9b01036dcdcaf66b6156df05
MISC metadata.xml 392 BLAKE2B d2aa6fc43f7f9038d320197a18107f15e56ed5e242e6c3cdc1b7111184580ab14fae8cbd16776794d207dd39ea0ca65975c08a54449f4cf90370ea95a66083d9 SHA512 867c61c1e41d7594decd5e10a2b45d934313cb751ba22356fc1ab61e0a40b2543847b195d20c7a39ba92370d8b3908e6f90d690915579b55808872efe8d3cebe
diff --git a/net-misc/yt-dlp/yt-dlp-2024.03.10.ebuild b/net-misc/yt-dlp/yt-dlp-2024.03.10.ebuild
new file mode 100644
index 000000000000..3e90f2adfdf4
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.03.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}