summaryrefslogtreecommitdiff
path: root/net-misc/yt-dlp
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/yt-dlp')
-rw-r--r--net-misc/yt-dlp/Manifest2
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.04.09.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index b447b3a307e0..b1fb3a5e58f7 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,4 +1,6 @@
DIST yt-dlp-2024.03.10.tar.gz 5515436 BLAKE2B ce25d2ce78ebd107deab12a117ac9efa634052264d780c62531226c7128b1ba5ca52c952dc85dcefe137aadf08cffa417a135b996f864315866c35fd7209ec6b SHA512 6bfe1aeab98f559a2b23ffa12b63b40974312709039313695f41c7beb16d29f21953c61ab633d567e42deeec72fb0932950ddeb4b821fffb93fbae9ae0cb30a2
+DIST yt-dlp-2024.04.09.tar.gz 5589808 BLAKE2B ada1c3be28c4615a96b4fef9d39144b49548e97be6fab003596f11db905efa2607ea3d62ba529aee8391320bf4e3cd3c9367a5eab0439822fd98407fde2807fb SHA512 5eada1c6a3d656c4f70552824a59ed677ecc102e1a2c3475a12fccff78ea267d7391e778060d708bf0aca1bdf92f4bf413785e0cd65b43259535577e92755556
EBUILD yt-dlp-2024.03.10.ebuild 2157 BLAKE2B c422780dff4567646bef0607b514d67da611ef452b780cae916eb4ecb603865053d938920096ba41919b0d668650e61975d365d83fbacbb7a2726c801dcfbd0d SHA512 147c30d384325bafb66248479e3859c6f1db4cf1f0a03ea13bfdcc1a72c3e675cae8490be426a66c3494384c448625313a5b1f0a006b7973260c1ae5245a14ff
+EBUILD yt-dlp-2024.04.09.ebuild 2269 BLAKE2B eb96848de26497f48ca862fe6210c94dbf0d665654c8fc1d1c42b7e6ae387ed2c888956eb3c61bf5f338f791a0ce5a89c4b60d585560ec08d1a65775651d9567 SHA512 9a0afcf5f43bd7bd231b6584885b80cbb8e7850a6cd85e826a44b4351e8d27158e74e0d20fefe65c4cb1bf0acbcc9b62aeb7c76953cac070a64685746766f8f4
EBUILD yt-dlp-9999.ebuild 2436 BLAKE2B 7c055a00c39eb58ad7554bf0bd8ee7d66a442dadac1659ea8788f882d07b5f5793656d04ad00c364d6692088540c03b63b6eb71da373029b7f65bbbb9702d759 SHA512 95a1fbebad00914dc6ca24ef4966bf0ee02a80f5a8408134829d841c96d70f262497b31753eb827bc0371598af6a575be97874f9a605789dbf14d524c99184b0
MISC metadata.xml 392 BLAKE2B d2aa6fc43f7f9038d320197a18107f15e56ed5e242e6c3cdc1b7111184580ab14fae8cbd16776794d207dd39ea0ca65975c08a54449f4cf90370ea95a66083d9 SHA512 867c61c1e41d7594decd5e10a2b45d934313cb751ba22356fc1ab61e0a40b2543847b195d20c7a39ba92370d8b3908e6f90d690915579b55808872efe8d3cebe
diff --git a/net-misc/yt-dlp/yt-dlp-2024.04.09.ebuild b/net-misc/yt-dlp/yt-dlp-2024.04.09.ebuild
new file mode 100644
index 000000000000..f811e455142d
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.04.09.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}