summaryrefslogtreecommitdiff
path: root/net-misc/xmrig/xmrig-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/xmrig/xmrig-9999.ebuild')
-rw-r--r--net-misc/xmrig/xmrig-9999.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/net-misc/xmrig/xmrig-9999.ebuild b/net-misc/xmrig/xmrig-9999.ebuild
index a36872e00718..2061563b6ac5 100644
--- a/net-misc/xmrig/xmrig-9999.ebuild
+++ b/net-misc/xmrig/xmrig-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake flag-o-matic systemd toolchain-funcs
+inherit cmake systemd
DESCRIPTION="RandomX, CryptoNight, KawPow, AstroBWT, and Argon2 CPU/GPU miner"
HOMEPAGE="https://xmrig.com https://github.com/xmrig/xmrig"
@@ -44,13 +44,6 @@ src_prepare() {
}
src_configure() {
- # JIT broken with FORTIFY_SOURCE=3
- # Bug #913420
- if tc-enables-fortify-source; then
- filter-flags -D_FORTIFY_SOURCE=3
- append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
- fi
-
local mycmakeargs=(
-DWITH_SSE4_1=$(usex cpu_flags_x86_sse4_1)
-DWITH_HWLOC=$(usex hwloc)