summaryrefslogtreecommitdiff
path: root/net-misc/ttytter/ttytter-2.1.00.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ttytter/ttytter-2.1.00.ebuild')
-rw-r--r--net-misc/ttytter/ttytter-2.1.00.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/ttytter/ttytter-2.1.00.ebuild b/net-misc/ttytter/ttytter-2.1.00.ebuild
new file mode 100644
index 000000000000..585c023d30e2
--- /dev/null
+++ b/net-misc/ttytter/ttytter-2.1.00.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="A multi-functional, console-based Twitter client"
+HOMEPAGE="http://www.floodgap.com/software/ttytter/"
+SRC_URI="http://www.floodgap.com/software/ttytter/dist2/${PV}.txt -> ${P}.txt"
+
+LICENSE="FFSL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.8
+ || ( net-misc/curl www-client/lynx )"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin "${DISTDIR}/${A}" ${PN}
+
+ local DOC_CONTENTS="
+ Please consult the following webpage on how to
+ configure your client.
+ http://www.floodgap.com/software/ttytter/dl.html"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}