summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/streamlink/streamlink-9999.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild28
1 files changed, 26 insertions, 2 deletions
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index d73952536218..726f048e9ad9 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,7 @@ if [[ ${PV} != 9999* ]]; then
fi
# See https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358 for chardet/charset-normalizer dep
+# See https://github.com/streamlink/streamlink/pull/5895 re exceptiongroup dep
RDEPEND="
media-video/ffmpeg
$(python_gen_cond_dep '
@@ -38,6 +39,7 @@ RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/charset-normalizer[${PYTHON_USEDEP}]
)
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
>=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
@@ -45,7 +47,7 @@ RDEPEND="
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
- >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.25.0[${PYTHON_USEDEP}]
>=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
')
@@ -72,3 +74,25 @@ if [[ ${PV} == 9999* ]]; then
fi
distutils_enable_tests pytest
+
+python_test() {
+ # Skip tests requiring <dev-python/pytest-8.0.0 which is currently masked
+ # https://github.com/streamlink/streamlink/pull/5901
+ EPYTEST_DESELECT+=(
+ tests/webbrowser/cdp/test_client.py::TestEvaluate::test_exception
+ tests/webbrowser/cdp/test_client.py::TestEvaluate::test_error
+ tests/webbrowser/cdp/test_client.py::TestNavigate::test_detach
+ tests/webbrowser/cdp/test_client.py::TestNavigate::test_error
+ tests/webbrowser/cdp/test_connection.py::TestCreateConnection::test_failure
+ tests/webbrowser/cdp/test_connection.py::TestReaderError::test_invalid_json
+ tests/webbrowser/cdp/test_connection.py::TestReaderError::test_unknown_session_id
+ 'tests/webbrowser/cdp/test_connection.py::TestSend::test_timeout[Default timeout, response not in time]'
+ 'tests/webbrowser/cdp/test_connection.py::TestSend::test_timeout[Custom timeout, response not in time]'
+ tests/webbrowser/cdp/test_connection.py::TestSend::test_bad_command
+ tests/webbrowser/cdp/test_connection.py::TestSend::test_result_exception
+ tests/webbrowser/cdp/test_connection.py::TestHandleCmdResponse::test_response_error
+ tests/webbrowser/cdp/test_connection.py::TestHandleCmdResponse::test_response_no_result
+ )
+
+ epytest
+}