summaryrefslogtreecommitdiff
path: root/net-misc/streamlink/streamlink-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/streamlink/streamlink-0.1.0.ebuild')
-rw-r--r--net-misc/streamlink/streamlink-0.1.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/net-misc/streamlink/streamlink-0.1.0.ebuild b/net-misc/streamlink/streamlink-0.1.0.ebuild
deleted file mode 100644
index 7ce96657145b..000000000000
--- a/net-misc/streamlink/streamlink-0.1.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
-HOMEPAGE="https://streamlink.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="doc test"
-
-RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- virtual/python-singledispatch[${PYTHON_USEDEP}]
- media-video/rtmpdump"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}