summaryrefslogtreecommitdiff
path: root/net-misc/spread/spread-5.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/spread/spread-5.0.1.ebuild')
-rw-r--r--net-misc/spread/spread-5.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/spread/spread-5.0.1.ebuild b/net-misc/spread/spread-5.0.1.ebuild
new file mode 100644
index 000000000000..b7526d4dcd16
--- /dev/null
+++ b/net-misc/spread/spread-5.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit user
+
+MY_PN="spread-src"
+
+DESCRIPTION="Distributed network messaging system"
+HOMEPAGE="http://www.spread.org"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Spread-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ enewuser spread
+ enewgroup spread
+}
+
+src_prepare() {
+ default
+
+ # don't strip binaries
+ sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+}