summaryrefslogtreecommitdiff
path: root/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch')
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch b/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch
new file mode 100644
index 000000000000..9a3cdd090063
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.39-fix-finding-pyparsing.patch
@@ -0,0 +1,13 @@
+https://gitlab.freedesktop.org/spice/spice-common/-/issues/5
+https://bugs.gentoo.org/820074
+--- a/subprojects/spice-common/meson.build
++++ b/subprojects/spice-common/meson.build
+@@ -132,7 +132,7 @@ if spice_common_generate_client_code or spice_common_generate_server_code
+ if get_option('python-checks')
+ foreach module : ['six', 'pyparsing']
+ message('Checking for python module @0@'.format(module))
+- cmd = run_command(python, '-m', module)
++ cmd = run_command(python, '-c', 'import @0@'.format(module))
+ if cmd.returncode() != 0
+ error('Python module @0@ not found'.format(module))
+ endif