summaryrefslogtreecommitdiff
path: root/net-misc/sock/sock-1.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sock/sock-1.1-r2.ebuild')
-rw-r--r--net-misc/sock/sock-1.1-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/sock/sock-1.1-r2.ebuild b/net-misc/sock/sock-1.1-r2.ebuild
new file mode 100644
index 000000000000..dae97e0a2c19
--- /dev/null
+++ b/net-misc/sock/sock-1.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A shell interface to network sockets"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/linux.shtml"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/mj/net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 sparc x86"
+
+src_prepare() {
+ default
+
+ # Clang 16, bug #900256
+ eautoreconf
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ einstalldocs
+}