summaryrefslogtreecommitdiff
path: root/net-misc/socat/socat-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/socat/socat-9999.ebuild')
-rw-r--r--net-misc/socat/socat-9999.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/net-misc/socat/socat-9999.ebuild b/net-misc/socat/socat-9999.ebuild
index 7d28699e42fd..dada7a8478e0 100644
--- a/net-misc/socat/socat-9999.ebuild
+++ b/net-misc/socat/socat-9999.ebuild
@@ -1,18 +1,19 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools flag-o-matic git-r3 toolchain-funcs
+
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="Multipurpose relay (SOcket CAT)"
-HOMEPAGE="http://www.dest-unreach.org/socat/"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
EGIT_REPO_URI="https://repo.or.cz/${PN}.git"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE="libressl ssl readline ipv6 tcpd"
+IUSE="bindist libressl ssl readline ipv6 tcpd"
+BDEPEND="app-text/yodl"
DEPEND="
ssl? (
!libressl? ( dev-libs/openssl:0= )
@@ -21,24 +22,16 @@ DEPEND="
readline? ( sys-libs/readline:= )
tcpd? ( sys-apps/tcp-wrappers )
"
-BDEPEND="
- app-text/yodl
-"
-DEPEND="
- ${RDEPEND}
-"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
RESTRICT="
test
ssl? ( readline? ( bindist ) )
"
-DOCS=(
- BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
-)
-PATCHES=(
- "${FILESDIR}"/${PN}-1.7.3.4-fno-common.patch
- "${FILESDIR}"/${PN}-9999-stddef_h.patch
-)
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
pkg_setup() {
# bug #587740
@@ -51,13 +44,13 @@ pkg_setup() {
src_prepare() {
default
-
eautoreconf
}
src_configure() {
filter-flags '-Wno-error*' #293324
tc-export AR
+
econf \
$(use_enable ssl openssl) \
$(use_enable readline) \