summaryrefslogtreecommitdiff
path: root/net-misc/smbc/smbc-1.2.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/smbc/smbc-1.2.2-r3.ebuild')
-rw-r--r--net-misc/smbc/smbc-1.2.2-r3.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/net-misc/smbc/smbc-1.2.2-r3.ebuild b/net-misc/smbc/smbc-1.2.2-r3.ebuild
index 87ebd6eea0a6..434ea97b5718 100644
--- a/net-misc/smbc/smbc-1.2.2-r3.ebuild
+++ b/net-misc/smbc/smbc-1.2.2-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -11,20 +11,28 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="nls debug"
+BDEPEND="virtual/pkgconfig"
DEPEND="dev-libs/popt
net-fs/samba
sys-libs/ncurses
nls? ( sys-devel/gettext )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-size_t.patch
+ "${FILESDIR}"/${P}-samba4-includes.patch
+ "${FILESDIR}"/${P}-multiple-definitions-gcc10.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
src_prepare() {
default
mv configure.{in,ac} || die
- eapply "${FILESDIR}"/${P}-cflags.patch
- eapply "${FILESDIR}"/${P}-size_t.patch
+ # for some reason some build 32bit x86 objects are bundled
+ rm src/*.o
eautoreconf
}