summaryrefslogtreecommitdiff
path: root/net-misc/sipsak/sipsak-0.9.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sipsak/sipsak-0.9.8.ebuild')
-rw-r--r--net-misc/sipsak/sipsak-0.9.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/sipsak/sipsak-0.9.8.ebuild b/net-misc/sipsak/sipsak-0.9.8.ebuild
new file mode 100644
index 000000000000..765b6a9ffd0d
--- /dev/null
+++ b/net-misc/sipsak/sipsak-0.9.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="small command line tool for testing SIP applications and devices"
+HOMEPAGE="https://github.com/nils-ohlmeier/sipsak"
+SRC_URI="https://github.com/nils-ohlmeier/sipsak/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-dns/c-ares
+ net-libs/gnutls:="
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_configure() {
+ append-cflags -std=gnu89 -fcommon
+ econf
+}