summaryrefslogtreecommitdiff
path: root/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild')
-rw-r--r--net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild b/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..6be09aed0ddd
--- /dev/null
+++ b/net-misc/s4cmd/s4cmd-2.1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_10 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 bash-completion-r1
+
+DESCRIPTION="Super S3 command line tool"
+HOMEPAGE="https://github.com/bloomreach/s4cmd"
+SRC_URI="https://github.com/bloomreach/s4cmd/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/bloomreach/s4cmd/pull/310.patch -> ${P}-botocore-fix.patch "
+PATCHES=(
+ "${DISTDIR}/${P}-botocore-fix.patch"
+)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_install() {
+ distutils-r1_src_install
+ dobashcomp data/bash-completion/s4cmd
+ rm -f "${D}"/usr/bin/s4cmd.py
+}