summaryrefslogtreecommitdiff
path: root/net-misc/rwhoisd/rwhoisd-1.5.9.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rwhoisd/rwhoisd-1.5.9.6-r2.ebuild')
-rw-r--r--net-misc/rwhoisd/rwhoisd-1.5.9.6-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/rwhoisd/rwhoisd-1.5.9.6-r2.ebuild b/net-misc/rwhoisd/rwhoisd-1.5.9.6-r2.ebuild
new file mode 100644
index 000000000000..f1bdfc975450
--- /dev/null
+++ b/net-misc/rwhoisd/rwhoisd-1.5.9.6-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="ARIN rwhois daemon"
+HOMEPAGE="http://projects.arin.net/rwhois/"
+SRC_URI="https://github.com/arineng/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/libcrypt:="
+RDEPEND="
+ ${DEPEND}
+ acct-group/rwhoisd
+ acct-user/rwhoisd
+"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+"
+
+src_compile() {
+ append-cflags -DNEW_STYLE_BIN_SORT
+
+ emake -C common
+ emake -C regexp
+ emake -C mkdb
+
+ default
+}
+
+src_install() {
+ default
+
+ doinitd "${FILESDIR}"/rwhoisd
+ newconfd "${FILESDIR}"/rwhoisd.conf rwhoisd
+}
+
+pkg_postinst() {
+ einfo "Please make sure to set the userid in rwhoisd.conf to rwhoisd."
+ einfo "It is highly inadvisable to run rwhoisd as root."
+}