summaryrefslogtreecommitdiff
path: root/net-misc/rsync/rsync-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/rsync/rsync-9999.ebuild')
-rw-r--r--net-misc/rsync/rsync-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-misc/rsync/rsync-9999.ebuild b/net-misc/rsync/rsync-9999.ebuild
index 8c91d4f3a17a..0da8ff82f683 100644
--- a/net-misc/rsync/rsync-9999.ebuild
+++ b/net-misc/rsync/rsync-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit prefix systemd
+inherit flag-o-matic prefix systemd
DESCRIPTION="File transfer program to keep remote files into sync"
HOMEPAGE="https://rsync.samba.org/"
@@ -59,6 +59,10 @@ src_prepare() {
}
src_configure() {
+ # Force enable IPv6 on musl - upstream bug:
+ # https://bugzilla.samba.org/show_bug.cgi?id=10715
+ use elibc_musl && use ipv6 && append-cppflags -DINET6
+
local myeconfargs=(
--with-rsyncd-conf="${EPREFIX}"/etc/rsyncd.conf
--without-included-popt