summaryrefslogtreecommitdiff
path: root/net-misc/putty/putty-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/putty/putty-9999.ebuild')
-rw-r--r--net-misc/putty/putty-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-misc/putty/putty-9999.ebuild b/net-misc/putty/putty-9999.ebuild
index 5f8b56a4cf89..c677a8a6686d 100644
--- a/net-misc/putty/putty-9999.ebuild
+++ b/net-misc/putty/putty-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ inherit autotools eutils gnome2-utils git-r3 toolchain-funcs
DESCRIPTION="A Free Telnet/SSH Client"
HOMEPAGE="https://www.chiark.greenend.org.uk/~sgtatham/putty/"
-EGIT_REPO_URI="git://git.tartarus.org/simon/putty.git"
+EGIT_REPO_URI="https://git.tartarus.org/simon/putty.git"
SRC_URI="https://dev.gentoo.org/~jer/${PN}-icons.tar.bz2"
LICENSE="MIT"
@@ -62,6 +62,11 @@ src_compile() {
emake -C "${S}"/unix AR=$(tc-getAR) $(usex ipv6 '' COMPAT=-DNO_IPV6)
}
+src_test() {
+ emake -C unix cgtest
+ unix/cgtest || die
+}
+
src_install() {
dodoc doc/puttydoc.txt