summaryrefslogtreecommitdiff
path: root/net-misc/pssh/pssh-2.3.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pssh/pssh-2.3.4-r2.ebuild')
-rw-r--r--net-misc/pssh/pssh-2.3.4-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/pssh/pssh-2.3.4-r2.ebuild b/net-misc/pssh/pssh-2.3.4-r2.ebuild
new file mode 100644
index 000000000000..68c5f74fd4b4
--- /dev/null
+++ b/net-misc/pssh/pssh-2.3.4-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
+HOMEPAGE="https://github.com/lilydjwg/pssh"
+SRC_URI="https://github.com/lilydjwg/pssh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !net-misc/putty
+ net-misc/openssh
+"
+DEPEND="${RDEPEND}"
+
+# Requires ssh access to run.
+RESTRICT="test"
+
+python_prepare_all() {
+ sed -i -e "s|man/man1'|share/&|g" setup.py || die
+ distutils-r1_python_prepare_all
+}