summaryrefslogtreecommitdiff
path: root/net-misc/portspoof
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/portspoof')
-rw-r--r--net-misc/portspoof/Manifest4
-rw-r--r--net-misc/portspoof/portspoof-1.3-r1.ebuild (renamed from net-misc/portspoof/portspoof-1.3.ebuild)22
-rw-r--r--net-misc/portspoof/portspoof-9999.ebuild22
3 files changed, 38 insertions, 10 deletions
diff --git a/net-misc/portspoof/Manifest b/net-misc/portspoof/Manifest
index 485783f06260..28c6ad0fb985 100644
--- a/net-misc/portspoof/Manifest
+++ b/net-misc/portspoof/Manifest
@@ -1,4 +1,4 @@
DIST portspoof-1.3.tar.gz 401187 BLAKE2B 340e7003e3ad36afeb53981d0628d13ec48afd9260fdd9f17b76b904b3da58d82dc23b455da24567545d60b29f2f358b11f4a07e83ae2192470fa40099f93c1c SHA512 8d537ecf2ae5de8388c2b9b7210a2d38fe614e525a2ba286321fcf3b237f0888e59bb79a80056e49cf7f850be8ef274e87f04597a50dc1b86350bbc094e8be6e
-EBUILD portspoof-1.3.ebuild 982 BLAKE2B 2d09d232985d54d4dd5fa9c162b580425139cbf218c5ee57173dd523e46b61363dd728c1332812af86262b37938d8353d7fdf3e23163b58cc43ffc217df1b344 SHA512 9604873cc00f0c811b1e5c2a5950e41e15c19bed7a3fdb8d0c887bd2fd6a848aabe16a99dd3418010b1bbd08d2aae800d3ebd6bb6c681e2ef5436593e4616c16
-EBUILD portspoof-9999.ebuild 982 BLAKE2B 2d09d232985d54d4dd5fa9c162b580425139cbf218c5ee57173dd523e46b61363dd728c1332812af86262b37938d8353d7fdf3e23163b58cc43ffc217df1b344 SHA512 9604873cc00f0c811b1e5c2a5950e41e15c19bed7a3fdb8d0c887bd2fd6a848aabe16a99dd3418010b1bbd08d2aae800d3ebd6bb6c681e2ef5436593e4616c16
+EBUILD portspoof-1.3-r1.ebuild 1223 BLAKE2B 7ecd295a5dc4e84eac3edb981797f0fc98df0a1b904f906bfb0e60e38c1d90bb20a15aba7488688c7ecbb4c5e87d367b83bbfcf7cd13e80c745ea06f0476c387 SHA512 0ebf89e55054b55bb3746bbdc46503f8f644dfa3663ae1037c4065d4c476c3b285977e5887bdfe69cbdcb3f4b5c2c63588f1c57e333efd2effa49cdb1657b612
+EBUILD portspoof-9999.ebuild 1223 BLAKE2B 7ecd295a5dc4e84eac3edb981797f0fc98df0a1b904f906bfb0e60e38c1d90bb20a15aba7488688c7ecbb4c5e87d367b83bbfcf7cd13e80c745ea06f0476c387 SHA512 0ebf89e55054b55bb3746bbdc46503f8f644dfa3663ae1037c4065d4c476c3b285977e5887bdfe69cbdcb3f4b5c2c63588f1c57e333efd2effa49cdb1657b612
MISC metadata.xml 329 BLAKE2B 00d1a1cc9f6abc0a1932cb60a8a97ac7befa4f6d2a422611be7e9ea8af33f214fab5a48659b5361dd5b8a0314160fd15f1224f8df05353e4d7dfeb9f10e249b6 SHA512 3b3aca166a18f20c72a54060d249514003d5cd12a6240d34a9b5d0441b4f82604c4071cecfbd0fab90bb870652b21ee3beeb62773a916af0e8c59410a79bc593
diff --git a/net-misc/portspoof/portspoof-1.3.ebuild b/net-misc/portspoof/portspoof-1.3-r1.ebuild
index aa2143647342..7eec0c399ab3 100644
--- a/net-misc/portspoof/portspoof-1.3.ebuild
+++ b/net-misc/portspoof/portspoof-1.3-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit flag-o-matic
DESCRIPTION="return SYN+ACK for every port connection attempt"
HOMEPAGE="http://portspoof.org/"
@@ -18,15 +20,27 @@ else
fi
src_prepare() {
+ default
if [[ ${PV} == "9999" ]] ; then
- mv configure.in configure.ac || die
+ mv configure.in configure.ac || die
eautoreconf
fi
sed -i \
's#/usr/local/bin/portspoof -D -c /usr/local/etc/portspoof.conf -s /usr/local/etc/portspoof_signatures#/usr/bin/portspoof -D -c /etc/portspoof.conf -s /etc/portspoof_signatures#'\
system_files/init.d/portspoof.sh
sed -i '/#include <sys\/sysctl.h>/d' src/connection.h || die
- eapply_user
+}
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861698
+ # https://github.com/drk1wi/portspoof/issues/48
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
}
src_install() {
diff --git a/net-misc/portspoof/portspoof-9999.ebuild b/net-misc/portspoof/portspoof-9999.ebuild
index aa2143647342..7eec0c399ab3 100644
--- a/net-misc/portspoof/portspoof-9999.ebuild
+++ b/net-misc/portspoof/portspoof-9999.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit flag-o-matic
DESCRIPTION="return SYN+ACK for every port connection attempt"
HOMEPAGE="http://portspoof.org/"
@@ -18,15 +20,27 @@ else
fi
src_prepare() {
+ default
if [[ ${PV} == "9999" ]] ; then
- mv configure.in configure.ac || die
+ mv configure.in configure.ac || die
eautoreconf
fi
sed -i \
's#/usr/local/bin/portspoof -D -c /usr/local/etc/portspoof.conf -s /usr/local/etc/portspoof_signatures#/usr/bin/portspoof -D -c /etc/portspoof.conf -s /etc/portspoof_signatures#'\
system_files/init.d/portspoof.sh
sed -i '/#include <sys\/sysctl.h>/d' src/connection.h || die
- eapply_user
+}
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861698
+ # https://github.com/drk1wi/portspoof/issues/48
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
}
src_install() {