summaryrefslogtreecommitdiff
path: root/net-misc/portspoof/portspoof-1.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/portspoof/portspoof-1.3-r1.ebuild')
-rw-r--r--net-misc/portspoof/portspoof-1.3-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/portspoof/portspoof-1.3-r1.ebuild b/net-misc/portspoof/portspoof-1.3-r1.ebuild
new file mode 100644
index 000000000000..7eec0c399ab3
--- /dev/null
+++ b/net-misc/portspoof/portspoof-1.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="return SYN+ACK for every port connection attempt"
+HOMEPAGE="http://portspoof.org/"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/drk1wi/${PN}.git"
+else
+ SRC_URI="https://github.com/drk1wi/portspoof/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ mv configure.in configure.ac || die
+ eautoreconf
+ fi
+ sed -i \
+ 's#/usr/local/bin/portspoof -D -c /usr/local/etc/portspoof.conf -s /usr/local/etc/portspoof_signatures#/usr/bin/portspoof -D -c /etc/portspoof.conf -s /etc/portspoof_signatures#'\
+ system_files/init.d/portspoof.sh
+ sed -i '/#include <sys\/sysctl.h>/d' src/connection.h || die
+}
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861698
+ # https://github.com/drk1wi/portspoof/issues/48
+ #
+ # Do not trust it with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
+src_install() {
+ default_src_install
+ newsbin system_files/init.d/portspoof.sh portspoof-runner
+}