summaryrefslogtreecommitdiff
path: root/net-misc/openvswitch/openvswitch-2.10.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openvswitch/openvswitch-2.10.1-r1.ebuild')
-rw-r--r--net-misc/openvswitch/openvswitch-2.10.1-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/net-misc/openvswitch/openvswitch-2.10.1-r1.ebuild b/net-misc/openvswitch/openvswitch-2.10.1-r1.ebuild
index f74b7fd5ea74..35f6bd871b8f 100644
--- a/net-misc/openvswitch/openvswitch-2.10.1-r1.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.10.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
inherit autotools eutils linux-info linux-mod python-r1 systemd
@@ -66,6 +66,10 @@ src_configure() {
# pyside is staticly disabled
export ovs_cv_pyuic4="no"
+ # flake8 is primarily a style guide tool, running it as part of the tests
+ # in Gentoo does not make much sense, only breaks them: bug 607280
+ export ovs_cv_flake8="no"
+
local linux_config
use modules && linux_config="--with-linux=${KV_OUT_DIR}"