summaryrefslogtreecommitdiff
path: root/net-misc/openssh/openssh-8.0_p1-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openssh/openssh-8.0_p1-r4.ebuild')
-rw-r--r--net-misc/openssh/openssh-8.0_p1-r4.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/net-misc/openssh/openssh-8.0_p1-r4.ebuild b/net-misc/openssh/openssh-8.0_p1-r4.ebuild
index 5393ca2b81d5..2acc872e9ccc 100644
--- a/net-misc/openssh/openssh-8.0_p1-r4.ebuild
+++ b/net-misc/openssh/openssh-8.0_p1-r4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit user eapi7-ver flag-o-matic multilib autotools pam systemd
+inherit eapi7-ver flag-o-matic multilib autotools pam systemd
# Make it more portable between straight releases
# and _p? releases.
@@ -32,7 +32,7 @@ SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
LICENSE="BSD GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# Probably want to drop ssl defaulting to on in a future version.
IUSE="abi_mips_n32 audit bindist debug hpn kerberos kernel_linux ldns libedit libressl livecd pam +pie sctp selinux +ssl static test X X509 xmss"
RESTRICT="!test? ( test )"
@@ -67,6 +67,8 @@ LIB_DEPEND="
)
>=sys-libs/zlib-1.2.3:=[static-libs(+)]"
RDEPEND="
+ acct-group/sshd
+ acct-user/sshd
!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
pam? ( sys-libs/pam )
kerberos? ( virtual/krb5 )"
@@ -123,6 +125,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-8.0_p1-deny-shmget-shmat-shmdt-in-preauth-privsep-child.patch
eapply "${FILESDIR}"/${PN}-8.0_p1-fix-integer-overflow-in-XMSS-private-key-parsing.patch
eapply "${FILESDIR}"/${PN}-8.0_p1-fix-an-unreachable-integer-overflow-similar-to-the-XMSS-case.patch
+ eapply "${FILESDIR}"/${PN}-8.1_p1-tests-2020.patch
use X509 || eapply "${FILESDIR}"/${PN}-8.0_p1-tests.patch
[[ -d ${WORKDIR}/patches ]] && eapply "${WORKDIR}"/patches
@@ -410,11 +413,6 @@ src_install() {
systemd_newunit "${FILESDIR}"/sshd_at.service 'sshd@.service'
}
-pkg_preinst() {
- enewgroup sshd 22
- enewuser sshd 22 -1 /var/empty sshd
-}
-
pkg_postinst() {
if has_version "<${CATEGORY}/${PN}-5.8_p1" ; then
elog "Starting with openssh-5.8p1, the server will default to a newer key"