summaryrefslogtreecommitdiff
path: root/net-misc/nyx/nyx-2.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/nyx/nyx-2.0.4.ebuild')
-rw-r--r--net-misc/nyx/nyx-2.0.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-misc/nyx/nyx-2.0.4.ebuild b/net-misc/nyx/nyx-2.0.4.ebuild
new file mode 100644
index 000000000000..93d2f04eb224
--- /dev/null
+++ b/net-misc/nyx/nyx-2.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit vcs-snapshot distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ net-libs/stem
+ net-vpn/tor"