summaryrefslogtreecommitdiff
path: root/net-misc/netifrc/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/netifrc/files')
-rw-r--r--net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch26
-rw-r--r--net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_args_tempfile.patch65
-rw-r--r--net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_pidfile_location.patch50
3 files changed, 115 insertions, 26 deletions
diff --git a/net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch b/net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch
deleted file mode 100644
index 5f00dc1bb101..000000000000
--- a/net-misc/netifrc/files/netifrc-0.4.0-interface-types.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 18dd0598b29d2158529466f1e7097bf894e584dc Mon Sep 17 00:00:00 2001
-From: Andrey Volkov <volkov.am@ekb-info.ru>
-Date: Fri, 15 Jul 2016 13:23:56 +0500
-Subject: Fix missing interface types
-
-(cherry picked from commit c8fe42141c95f5446dabf5c0b1f049151e51c2ad)
----
- net/Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/net/Makefile b/net/Makefile
-index a03c171..ce73c1e 100644
---- a/net/Makefile
-+++ b/net/Makefile
-@@ -13,7 +13,7 @@ SRCS-Linux= iwconfig.sh.in udhcpc.sh.in
- INC-Linux= adsl.sh apipa.sh arping.sh bonding.sh br2684ctl.sh bridge.sh \
- ccwgroup.sh clip.sh ethtool.sh iproute2.sh ifplugd.sh ip6to4.sh \
- ipppd.sh iwconfig.sh netplugd.sh pppd.sh pump.sh tuntap.sh udhcpc.sh \
-- vlan.sh macvlan.sh ip6rd.sh firewalld.sh
-+ vlan.sh macvlan.sh ip6rd.sh firewalld.sh dummy.sh hsr.sh l2tp.sh
-
- SRCS-NetBSD= ifwatchd.sh.in
- INC-NetBSD= ifwatchd.sh
---
-cgit v0.12
-
diff --git a/net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_args_tempfile.patch b/net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_args_tempfile.patch
new file mode 100644
index 000000000000..6ad40c860f96
--- /dev/null
+++ b/net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_args_tempfile.patch
@@ -0,0 +1,65 @@
+From 586579d5c9fad63eb8780c556f34b80d0302e6b9 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 22 May 2020 10:09:22 +0200
+Subject: [PATCH] net/dhcpcd.sh: Put user args into a temp file
+
+So we still use the correct PID even if the user has changed his
+configuration between start and stop.
+
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ net/dhcpcd.sh | 20 ++++++++++++++------
+ 1 file changed, 14 insertions(+), 6 deletions(-)
+
+diff --git a/net/dhcpcd.sh b/net/dhcpcd.sh
+index c0639e0..dcc6817 100644
+--- a/net/dhcpcd.sh
++++ b/net/dhcpcd.sh
+@@ -16,11 +16,14 @@ _config_vars="$_config_vars dhcp dhcpcd"
+
+ dhcpcd_start()
+ {
+- # check for pidfile after we gathered the user's opts because they can
++ # check for pidfile after we gathered the user's args because they can
+ # alter the pidfile's name (#718114)
+- local args= opt= pidfile= opts= new=true
++ # Save the args into a file so dhcpcd_stop can later re-use the very
++ # same args later.
++ local args= opt= pidfile= opts= new=true argsfile=/run/netifrc_dhcpcd_${IFACE}_args
+ eval args=\$dhcpcd_${IFVAR}
+ [ -z "${args}" ] && args=${dhcpcd}
++ echo "${args}" > ${argsfile}
+ pidfile="$(dhcpcd -P ${args} ${IFACE})"
+
+ # Get our options
+@@ -78,12 +81,16 @@ dhcpcd_start()
+
+ dhcpcd_stop()
+ {
+- local args= pidfile= opts= sig=SIGTERM
++ local args= pidfile= opts= sig=SIGTERM argsfile=/run/netifrc_dhcpcd_${IFACE}_args
+
+- # check for pidfile after we gathered the user's opts because they can
++ # check for pidfile after we gathered the user's args because they can
+ # alter the pidfile's name (#718114)
+- eval args=\$dhcpcd_${IFVAR}
+- [ -z "${args}" ] && args=${dhcpcd}
++ if [ -f "${argsfile}" ] ; then
++ args="$(cat ${argsfile})"
++ else
++ eval args=\$dhcpcd_${IFVAR}
++ [ -z "${args}" ] && args=${dhcpcd}
++ fi
+ pidfile="$(dhcpcd -P ${args} ${IFACE})"
+ [ ! -f "${pidfile}" ] && return 0
+
+@@ -94,5 +101,6 @@ dhcpcd_stop()
+ *" release "*) dhcpcd -k "${IFACE}" ;;
+ *) dhcpcd -x "${IFACE}" ;;
+ esac
++ [ -f "${argsfile}" ] && rm -f "${argsfile}"
+ eend $?
+ }
+--
+2.27.0.rc0
+
diff --git a/net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_pidfile_location.patch b/net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_pidfile_location.patch
new file mode 100644
index 000000000000..154e7a7696a0
--- /dev/null
+++ b/net-misc/netifrc/files/netifrc-0.7.1-dhcpcd_pidfile_location.patch
@@ -0,0 +1,50 @@
+From c29dffb14e321d927196a9b39b545004e632d3c4 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Thu, 21 May 2020 18:35:32 +0200
+Subject: [PATCH] net/dhcpcd.sh: fetch pidfile location from dhcpcd
+
+There's a -P switch for this but we also need to take into account the
+-4 and -6 switches as they both alter the pidfile's name.
+
+Bug: https://bugs.gentoo.org/718114
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ net/dhcpcd.sh | 13 +++++++++++--
+ 1 file changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/net/dhcpcd.sh b/net/dhcpcd.sh
+index 0a306b8..c0639e0 100644
+--- a/net/dhcpcd.sh
++++ b/net/dhcpcd.sh
+@@ -16,9 +16,12 @@ _config_vars="$_config_vars dhcp dhcpcd"
+
+ dhcpcd_start()
+ {
+- local args= opt= opts= pidfile="/run/dhcpcd-${IFACE}.pid" new=true
++ # check for pidfile after we gathered the user's opts because they can
++ # alter the pidfile's name (#718114)
++ local args= opt= pidfile= opts= new=true
+ eval args=\$dhcpcd_${IFVAR}
+ [ -z "${args}" ] && args=${dhcpcd}
++ pidfile="$(dhcpcd -P ${args} ${IFACE})"
+
+ # Get our options
+ eval opts=\$dhcp_${IFVAR}
+@@ -75,7 +78,13 @@ dhcpcd_start()
+
+ dhcpcd_stop()
+ {
+- local pidfile="/run/dhcpcd-${IFACE}.pid" opts= sig=SIGTERM
++ local args= pidfile= opts= sig=SIGTERM
++
++ # check for pidfile after we gathered the user's opts because they can
++ # alter the pidfile's name (#718114)
++ eval args=\$dhcpcd_${IFVAR}
++ [ -z "${args}" ] && args=${dhcpcd}
++ pidfile="$(dhcpcd -P ${args} ${IFACE})"
+ [ ! -f "${pidfile}" ] && return 0
+
+ ebegin "Stopping dhcpcd on ${IFACE}"
+--
+2.27.0.rc0
+