summaryrefslogtreecommitdiff
path: root/net-misc/ndisc6/ndisc6-1.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ndisc6/ndisc6-1.0.6.ebuild')
-rw-r--r--net-misc/ndisc6/ndisc6-1.0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/ndisc6/ndisc6-1.0.6.ebuild b/net-misc/ndisc6/ndisc6-1.0.6.ebuild
new file mode 100644
index 000000000000..9118a255354e
--- /dev/null
+++ b/net-misc/ndisc6/ndisc6-1.0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Recursive DNS Servers discovery Daemon (rdnssd) for IPv6"
+HOMEPAGE="https://www.remlab.net/ndisc6/"
+SRC_URI="https://www.remlab.net/files/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86 ~x64-macos"
+IUSE="debug"
+
+BDEPEND="dev-lang/perl
+ sys-devel/gettext"
+
+src_configure() {
+ econf $(use_enable debug assert)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ newinitd "${FILESDIR}"/rdnssd.rc-1 rdnssd
+ newconfd "${FILESDIR}"/rdnssd.conf rdnssd
+
+ exeinto /etc/rdnssd
+ newexe "${FILESDIR}"/resolvconf-1 resolvconf
+ dodoc AUTHORS ChangeLog NEWS README
+
+ keepdir /var/lib/run/rdnssd
+}