summaryrefslogtreecommitdiff
path: root/net-misc/mrouted/mrouted-4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/mrouted/mrouted-4.2.ebuild')
-rw-r--r--net-misc/mrouted/mrouted-4.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/mrouted/mrouted-4.2.ebuild b/net-misc/mrouted/mrouted-4.2.ebuild
new file mode 100644
index 000000000000..47de037fe009
--- /dev/null
+++ b/net-misc/mrouted/mrouted-4.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs systemd
+
+DESCRIPTION="IP multicast routing daemon"
+HOMEPAGE="https://troglobit.com/projects/mrouted/"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="Stanford GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="rsrr"
+
+BDEPEND="
+ || ( dev-util/yacc sys-devel/bison )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ tc-export CC CXX
+ econf $(usex rsrr --enable-rsrr '')
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ doins mrouted.conf
+
+ newinitd "${FILESDIR}"/mrouted.rc mrouted
+ systemd_dounit mrouted.service
+}