summaryrefslogtreecommitdiff
path: root/net-misc/mico/mico-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/mico/mico-9999.ebuild')
-rw-r--r--net-misc/mico/mico-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/net-misc/mico/mico-9999.ebuild b/net-misc/mico/mico-9999.ebuild
index ba56c4b4614b..4b4032d1f826 100644
--- a/net-misc/mico/mico-9999.ebuild
+++ b/net-misc/mico/mico-9999.ebuild
@@ -8,22 +8,21 @@ inherit flag-o-matic toolchain-funcs autotools
if [[ ${PV} == 9999 ]]; then
EDARCS_REPOSITORY="http://www.mico.org/mico-darcs-repository"
inherit darcs
- SRC_URI="https://github.com/haubi/mico/compare/gentoo.patch -> ${P}-gentoo.patch"
- PATCHES="${DISTDIR}/${P}-gentoo.patch"
+ SRC_URI=""
+ PATCHES="${WORKDIR}/${P}-gentoo.patch"
else
- PATCH_VER=20170529
SRC_URI="
http://www.mico.org/${P}.tar.gz
- https://dev.gentoo.org/~haubi/distfiles/${P}-gentoo-patches-${PATCH_VER}.tar.xz
+ https://github.com/haubi/mico/compare/${PV}-raw...${PV}-gentoo-${PR}.patch -> ${P}-gentoo-${PR}.patch
"
- PATCHES="${WORKDIR}/patches"
+ PATCHES="${DISTDIR}/${P}-gentoo-${PR}.patch"
+ KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-winnt"
fi
DESCRIPTION="A freely available and fully compliant implementation of the CORBA standard"
HOMEPAGE="http://www.mico.org/"
LICENSE="GPL-2 LGPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="gtk postgres ssl tcl threads X"
RESTRICT="test" #298101
@@ -45,6 +44,7 @@ BDEPEND="
if [[ ${PV} == 9999 ]]; then
src_unpack() {
+ wget -O ${P}-gentoo.patch "https://github.com/haubi/mico/compare/gentoo.patch" || die
darcs_src_unpack
default
}
@@ -66,6 +66,7 @@ src_prepare() {
src_configure() {
tc-export CC CXX
+ append-cxxflags -fno-strict-aliasing
# Don't know which version of JavaCUP would suffice, but there is no
# configure argument to disable checking for JavaCUP.
@@ -131,6 +132,7 @@ src_install() {
mv "${ED}"/usr/doc "${ED}"/usr/share/doc/${PF} || die
dodoc BUGS CHANGES* CONVERT README* ROADMAP TODO VERSION WTODO
+ [[ ${PV} == 9999 ]] || dodoc FAQ
}
pkg_postinst() {