summaryrefslogtreecommitdiff
path: root/net-misc/linuxptp
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/linuxptp')
-rw-r--r--net-misc/linuxptp/Manifest2
-rw-r--r--net-misc/linuxptp/linuxptp-2.0.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/net-misc/linuxptp/Manifest b/net-misc/linuxptp/Manifest
index 039cda7c5b54..6194799c21c0 100644
--- a/net-misc/linuxptp/Manifest
+++ b/net-misc/linuxptp/Manifest
@@ -1,3 +1,3 @@
DIST linuxptp-2.0.tgz 184942 BLAKE2B 79ef9d3c379769a71e652a77f05ab661db444a76a339e72106055cf900de9cabfe303c48760f11701fefe5e641d07b73fc5a250078bedf7faa3ae995ace24da3 SHA512 c33487a803f8cc461f790d9a137d5cf8b35cb6d292bdd2cf7a16aa666359d8c5e24667473be843182bef1e9f8d5c6af8aab8918978f10bf08257dd408bba66d6
-EBUILD linuxptp-2.0.ebuild 762 BLAKE2B 4aae3a869826fc311459f7bb2aeda456c6ab3cb09378842361b85f8e98a7915550451c4d9efd67f1fe751b6e78cee5fd99e13731b4e7b175cb99cb4e5ee8d964 SHA512 85bb3b3f52ca6744b33fa4e04d0e5bf96698c90bf2bc442edca4e11ac6741437f68e3d34019acfc5cc927a674bf0b2afcd4c96c03ab27f7f0204cf09a44cd5d0
+EBUILD linuxptp-2.0.ebuild 882 BLAKE2B 41e6f6c8999e290e3c574582cca7254c728a75496935d5458e3eb3b69a2c0f3237068bb587ac7289ffa429fa08cb223fed457eff3996506b84771b5d0e852cdc SHA512 16dab620bf44d59006907dfa41be1db8032af0e541008979e54d73e8ed659da65efe460f5a54445511a41953e1ff671315f129c10d661738884f7ddc74dfacf9
MISC metadata.xml 445 BLAKE2B abfb043154cd84cb3a40212f54d9be67e89bfda3f83cdb9a8d65d8032b8d1f0a0b8dcfb4fdbaa5ed303dfa65f35715ee714a84026b730c26964a1e06a41b32e2 SHA512 6016bb962e61088156d9f2b78d8dfc0f4b07e6a22016d7d591459b8254ef42798c902a2cdfe183972703d3c1911ab48d7b3c95a0bc1b470a4dcc1a34ea66d232
diff --git a/net-misc/linuxptp/linuxptp-2.0.ebuild b/net-misc/linuxptp/linuxptp-2.0.ebuild
index 716fbf22a46d..3569ecc3c668 100644
--- a/net-misc/linuxptp/linuxptp-2.0.ebuild
+++ b/net-misc/linuxptp/linuxptp-2.0.ebuild
@@ -19,8 +19,14 @@ RDEPEND="${DEPEND}"
CONFIG_CHECK="~PPS ~NETWORK_PHY_TIMESTAMPING ~PTP_1588_CLOCK"
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
src_compile() {
- export EXTRA_CFLAGS=${CFLAGS}
+ # parse needed additional CFLAGS
+ export MY_FLAGS=$(./incdefs.sh)
+ export EXTRA_CFLAGS="${CFLAGS} ${MY_FLAGS}"
emake CC="$(tc-getCC)" prefix=/usr mandir=/usr/share/man
}