summaryrefslogtreecommitdiff
path: root/net-misc/libteam/libteam-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/libteam/libteam-9999.ebuild')
-rw-r--r--net-misc/libteam/libteam-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/net-misc/libteam/libteam-9999.ebuild b/net-misc/libteam/libteam-9999.ebuild
index 23c3186d0a44..bd9779d7355e 100644
--- a/net-misc/libteam/libteam-9999.ebuild
+++ b/net-misc/libteam/libteam-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools linux-info
+inherit autotools linux-info systemd
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/jpirko/${PN}.git"
@@ -20,15 +20,16 @@ LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="dbus debug examples static-libs +syslog zmq"
-DEPEND=">=dev-libs/jansson-2.4:=
+DEPEND="
+ >=dev-libs/jansson-2.4:=
dev-libs/libdaemon
>=dev-libs/libnl-3.2.19[utils]
dbus? ( sys-apps/dbus )
zmq? ( >=net-libs/zeromq-3.2.0 )
- "
-
+"
RDEPEND="${DEPEND}
- syslog? ( virtual/logger )"
+ syslog? ( virtual/logger )
+"
CONFIG_CHECK="~NET_TEAM ~NET_TEAM_MODE_ROUNDROBIN ~NET_TEAM_MODE_ACTIVEBACKUP ~NET_TEAM_MODE_BROADCAST ~NET_TEAM_MODE_RANDOM ~NET_TEAM_MODE_LOADBALANCE"
ERROR_NET_TEAM="NET_TEAM is not enabled in this kernel!
@@ -40,11 +41,13 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable syslog logging) \
- $(use_enable dbus) \
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable syslog logging)
+ $(use_enable dbus)
$(use_enable zmq)
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {
@@ -54,6 +57,7 @@ src_install() {
insinto /etc/dbus-1/system.d
doins teamd/dbus/teamd.conf
+ systemd_dounit teamd/redhat/systemd/teamd@.service
if use examples; then
docinto examples