summaryrefslogtreecommitdiff
path: root/net-misc/kea/kea-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/kea/kea-9999.ebuild')
-rw-r--r--net-misc/kea/kea-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/net-misc/kea/kea-9999.ebuild b/net-misc/kea/kea-9999.ebuild
index 2c411fe395c2..72c97487d6f6 100644
--- a/net-misc/kea/kea-9999.ebuild
+++ b/net-misc/kea/kea-9999.ebuild
@@ -71,11 +71,15 @@ pkg_setup() {
src_prepare() {
default
- cp "${FILESDIR}"/ax_gtest.m4 "${S}"/m4macros/ax_gtest.m4 || die 'Replace gtest m4 macro failed'
+ if use test; then
+ cp "${FILESDIR}"/ax_gtest.m4 "${S}"/m4macros/ax_gtest.m4 || die 'Replace gtest m4 macro failed'
+ fi
# brand the version with Gentoo
sed -i \
- -e "s/AC_INIT(kea,${PV}.*, kea-dev@lists.isc.org)/AC_INIT([kea], [${PVR}-gentoo], [kea-dev@lists.isc.org])/g" \
+ -e 's/KEA_SRCID="tarball"/KEA_SRCID="gentoo"/g' \
+ -e 's/AC_MSG_RESULT("tarball")/AC_MSG_RESULT("gentoo")/g' \
+ -e "s/EXTENDED_VERSION=\"\${EXTENDED_VERSION} (\$KEA_SRCID)\"/EXTENDED_VERSION=\"${PVR} (\$KEA_SRCID)\"/g" \
configure.ac || die
sed -i \
@@ -105,7 +109,6 @@ src_configure() {
--with-log4cplus
$(use_enable debug)
$(use_enable doc generate-docs)
- $(use_enable test gtest)
$(use_enable shell)
$(use_with mysql)
$(use_with openssl)
@@ -115,7 +118,8 @@ src_configure() {
}
src_install() {
- default
+ emake -j1 install DESTDIR="${D}"
+
newconfd "${FILESDIR}"/${PN}-confd-r1 ${PN}
newinitd "${FILESDIR}"/${PN}-initd-r1 ${PN}