summaryrefslogtreecommitdiff
path: root/net-misc/kea/kea-1.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/kea/kea-1.8.2.ebuild')
-rw-r--r--net-misc/kea/kea-1.8.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-misc/kea/kea-1.8.2.ebuild b/net-misc/kea/kea-1.8.2.ebuild
index 3e20776fe7e7..8fa2128e5ae0 100644
--- a/net-misc/kea/kea-1.8.2.ebuild
+++ b/net-misc/kea/kea-1.8.2.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
-
MY_PV="${PV//_p/-P}"
MY_PV="${MY_PV/_/-}"
MY_P="${PN}-${MY_PV}"
@@ -15,6 +13,7 @@ if [[ ${PV} = 9999* ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/isc-projects/kea.git"
else
+ inherit autotools
SRC_URI="ftp://ftp.isc.org/isc/kea/${MY_P}.tar.gz
ftp://ftp.isc.org/isc/kea/${MY_PV}/${MY_P}.tar.gz"
[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
@@ -41,9 +40,11 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}"/${PN}-1.8.2-fix-cxx11-detection.patch )
+
src_prepare() {
default
- [[ ${PV} = *9999 ]] && eautoreconf
+ eautoreconf
# Brand the version with Gentoo
sed -i \
-e "/VERSION=/s:'$: Gentoo-${PR}':" \