summaryrefslogtreecommitdiff
path: root/net-misc/ipcalc/ipcalc-0.42_p2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ipcalc/ipcalc-0.42_p2.ebuild')
-rw-r--r--net-misc/ipcalc/ipcalc-0.42_p2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/ipcalc/ipcalc-0.42_p2.ebuild b/net-misc/ipcalc/ipcalc-0.42_p2.ebuild
new file mode 100644
index 000000000000..832a7b9c5242
--- /dev/null
+++ b/net-misc/ipcalc/ipcalc-0.42_p2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="IP Calculator prints broadcast/network/etc for an IP address and netmask"
+LICENSE="GPL-2+"
+HOMEPAGE="http://jodies.de/ipcalc"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p/-}.debian.tar.xz
+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+SLOT="0"
+
+RDEPEND=">=dev-lang/perl-5.6.0"
+S=${WORKDIR}/${PN}-0.5
+
+src_prepare() {
+ eapply "${WORKDIR}"/debian/patches/*.patch
+ eapply_user
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc changelog contributors README.md
+}