summaryrefslogtreecommitdiff
path: root/net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild')
-rw-r--r--net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild b/net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..06a8c2699a05
--- /dev/null
+++ b/net-misc/igmpproxy/igmpproxy-0.2.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit linux-info systemd
+
+DESCRIPTION="A multicast routing daemon which uses IGMP forwarding"
+HOMEPAGE="https://github.com/pali/igmpproxy"
+SRC_URI="https://github.com/pali/igmpproxy/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+CONFIG_CHECK="~IP_MULTICAST ~IP_MROUTE"
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/igmpproxy.initd" igmpproxy
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ newconfd "${FILESDIR}/igmpproxy.confd" igmpproxy
+}