summaryrefslogtreecommitdiff
path: root/net-misc/htpdate/htpdate-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/htpdate/htpdate-9999.ebuild')
-rw-r--r--net-misc/htpdate/htpdate-9999.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/net-misc/htpdate/htpdate-9999.ebuild b/net-misc/htpdate/htpdate-9999.ebuild
index 033790209271..eedff8c28a70 100644
--- a/net-misc/htpdate/htpdate-9999.ebuild
+++ b/net-misc/htpdate/htpdate-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic readme.gentoo-r1 toolchain-funcs
+inherit readme.gentoo-r1 toolchain-funcs
DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
-HOMEPAGE="https://github.com/angeloc/htpdate"
+HOMEPAGE="https://www.vervest.org/htp/"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/angeloc/htpdate.git"
+ EGIT_REPO_URI="https://github.com/twekkel/htpdate"
else
- SRC_URI="https://github.com/angeloc/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/twekkel/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
fi
IUSE="+ssl"
@@ -20,12 +20,14 @@ SLOT="0"
DEPEND="ssl? ( dev-libs/openssl:0= )"
RDEPEND="${DEPEND}"
-BDEPEND="ssl? ( virtual/pkgconfig )"
+
+# Test suite tries to connect to the Internet
+RESTRICT="test"
DOC_CONTENTS="If you would like to run htpdate as a daemon, set
appropriate http servers in /etc/conf.d/htpdate!"
-PATCHES=( "${FILESDIR}/${PN}-1.2.6-ldlibs.patch" )
+PATCHES=( )
src_prepare() {
default
@@ -37,17 +39,12 @@ src_prepare() {
}
src_compile() {
- if use ssl ; then
- append-cflags -DENABLE_HTTPS
- export PKG_CONFIG="$(tc-getPKG_CONFIG)"
- fi
-
- emake CFLAGS="-Wall ${CFLAGS}" CC="$(tc-getCC)" \
- $(usex ssl 'ENABLE_HTTPS=1' '')
+ emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ $(usex ssl "https" '')
}
src_install() {
- emake DESTDIR="${D}" bindir='$(prefix)/sbin' install
+ emake DESTDIR="${D}" STRIP="/bin/true" bindir='$(prefix)/sbin' install
dodoc README.md Changelog
newconfd "${FILESDIR}"/htpdate.conf htpdate