summaryrefslogtreecommitdiff
path: root/net-misc/htail/htail-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/htail/htail-1.5.ebuild')
-rw-r--r--net-misc/htail/htail-1.5.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-misc/htail/htail-1.5.ebuild b/net-misc/htail/htail-1.5.ebuild
index 3125e0a4d3ad..cb7f47746b65 100644
--- a/net-misc/htail/htail-1.5.ebuild
+++ b/net-misc/htail/htail-1.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 pypi
@@ -14,3 +14,4 @@ HOMEPAGE="https://github.com/vpelletier/htail"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+BDEPEND="${DISTUTILS_DEPS}"