summaryrefslogtreecommitdiff
path: root/net-misc/hotot/hotot-0.9.8.15_p20150812-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/hotot/hotot-0.9.8.15_p20150812-r2.ebuild')
-rw-r--r--net-misc/hotot/hotot-0.9.8.15_p20150812-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/hotot/hotot-0.9.8.15_p20150812-r2.ebuild b/net-misc/hotot/hotot-0.9.8.15_p20150812-r2.ebuild
new file mode 100644
index 000000000000..a15fe974e0db
--- /dev/null
+++ b/net-misc/hotot/hotot-0.9.8.15_p20150812-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 vcs-snapshot
+
+DESCRIPTION="lightweight & open source microblogging client"
+HOMEPAGE="http://hotot.org"
+SRC_URI="https://github.com/lyricat/Hotot/tarball/452fc0924a98923b -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="chrome kde qt5"
+
+REQUIRED_USE="|| ( chrome qt5 ) ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ mycmakeargs=(
+ ${mycmakeargs}
+ -DWITH_CHROME=$(usex chrome)
+ -DWITH_KDE=$(usex kde)
+ -DWITH_QT5=$(usex qt5)
+ -DPYTHON_EXECUTABLE=${PYTHON} )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ find "${D}" -name "*.pyc" -delete
+}
+
+pkg_postinst() {
+ if use chrome; then
+ elog "TO install hotot for chrome, open chromium/google-chrome,"
+ elog "vist chrome://chrome/extensions/ and load /usr/share/hotot"
+ elog "as unpacked extension."
+ fi
+}