summaryrefslogtreecommitdiff
path: root/net-misc/hath/hath-0.5.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/hath/hath-0.5.8.ebuild')
-rw-r--r--net-misc/hath/hath-0.5.8.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/hath/hath-0.5.8.ebuild b/net-misc/hath/hath-0.5.8.ebuild
new file mode 100644
index 000000000000..e3bd3cee062a
--- /dev/null
+++ b/net-misc/hath/hath-0.5.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Manipulate network blocks in CIDR notation"
+HOMEPAGE="https://michael.orlitzky.com/code/hath.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/cmdargs-0.10:=
+ >=dev-haskell/split-0.2:=
+ >=dev-haskell/tasty-0.8:=
+ >=dev-haskell/tasty-hunit-0.8:=
+ >=dev-haskell/tasty-quickcheck-0.8.1:=
+ >=dev-lang/ghc-9.0.0:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( dev-util/shelltestrunner )
+"
+
+src_install() {
+ cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}