summaryrefslogtreecommitdiff
path: root/net-misc/gensio
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gensio')
-rw-r--r--net-misc/gensio/Manifest4
-rw-r--r--net-misc/gensio/files/gensio-2.8.5-install-dir.patch16
-rw-r--r--net-misc/gensio/gensio-2.8.5.ebuild75
-rw-r--r--net-misc/gensio/metadata.xml17
4 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/gensio/Manifest b/net-misc/gensio/Manifest
new file mode 100644
index 000000000000..46dfe30dd00c
--- /dev/null
+++ b/net-misc/gensio/Manifest
@@ -0,0 +1,4 @@
+AUX gensio-2.8.5-install-dir.patch 656 BLAKE2B 342788bf6eaa8e6f4e04cdb8112d81e098e4f63c5782d1583156dd80e8e80cd3d27cb2b808731d712519c2a1b0e811c3f08acd9583a4de003e186e904a108404 SHA512 4e5c7b30c6c7c5aa65fd6ffdce05765d61190e3612beeadd1a37982ea34c9d5c655f94067ca567daa055341cd46c241b933c1a2e99e6e33fcde6ab44266f2868
+DIST gensio-2.8.5.tar.gz 1550476 BLAKE2B 4a000101a31ce0e1b9ee47e786a3a552b5b2e5863de67491bcfea0a61e55132220b5a62c6e40bb17aeae66ea57b651611e776b1446c6b1c3ac74452238295d95 SHA512 820bceca89085f830d0bdf05147ffa591f63a635311757d0af22a5a0284065e9b50e3bb4bea64bba1114c563e448d11e7f425c311b8f577d7f0f2d17944c9549
+EBUILD gensio-2.8.5.ebuild 1464 BLAKE2B 31b8cd606577d0ddb7c533fa817eeec2b19a852393101a5b7e324d3e65812985b63effb302929709103fd5a83ffdcc0b5affe20d383647957f7ca92de7adca18 SHA512 718776584738e39a3b85ef32973246c3986755b5043c7a7131a442a3cb42100f8ce15013fe55408e9e60eb11b411050e40e269daa5d285b021b27eacf2c3dde2
+MISC metadata.xml 512 BLAKE2B d4edf70d5238afadc071df0004d98acb9807c90a4d6e550e951ae0e8b2bee137ffe0d1e5953ae6261ca463774f3fd9d076439ef075631e780b5d8a20a05a3583 SHA512 0c37c3af17ccf246838db73e489b7560a0f75bdc9041cbbf31d05cdf45ce6bdcace11ece27c039d90bd191e1c4f6fcb650ff22688f5d80c75c197cb9a19841d9
diff --git a/net-misc/gensio/files/gensio-2.8.5-install-dir.patch b/net-misc/gensio/files/gensio-2.8.5-install-dir.patch
new file mode 100644
index 000000000000..ddea0cb55402
--- /dev/null
+++ b/net-misc/gensio/files/gensio-2.8.5-install-dir.patch
@@ -0,0 +1,16 @@
+--- gensio-2.8.5.orig/lib/Makefile.am 2024-06-18 21:45:20.427838306 -0700
++++ gensio-2.8.5/lib/Makefile.am 2024-06-18 21:46:09.360860952 -0700
+@@ -385,6 +385,7 @@
+ endif
+
+ install-exec-hook:
++ @(install -d $(DESTDIR)$(gensiolibexecdir))
+ @(cd $(DESTDIR)$(gensiolibexecdir) && $(RM) -f $(gensiolibexec_LTLIBRARIES))
+ @(cd $(DESTDIR)$(gensiolibexecdir) && $(RM) -f $(xgensio_libs))
+
+@@ -392,4 +393,5 @@
+ # libtool will not remove the .so or .dll files since the .la file is
+ # no longer there. We have to do that by hand.
+ uninstall-hook:
++ @(install -d $(DESTDIR)$(gensiolibexecdir))
+ @(cd $(DESTDIR)$(gensiolibexecdir) && $(RM) -f $(xgensio_solibs))
diff --git a/net-misc/gensio/gensio-2.8.5.ebuild b/net-misc/gensio/gensio-2.8.5.ebuild
new file mode 100644
index 000000000000..738d126edafe
--- /dev/null
+++ b/net-misc/gensio/gensio-2.8.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+DESCRIPTION="General Stream I/O"
+HOMEPAGE="https://sourceforge.net/projects/ser2net"
+SRC_URI="https://downloads.sourceforge.net/ser2net/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tcpd"
+
+DEPEND="
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+# Test suite requires a kernel module
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.8.5-install-dir.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-file-stdio \
+ --without-link-ssl-with-main \
+ --with-uucp-locking \
+ --with-flock-locking \
+ --without-broken-pselect \
+ --with-pthreads \
+ --without-glib \
+ --without-cplusplus \
+ --without-python \
+ --without-go \
+ --without-swig \
+ --without-all-gensios \
+ --without-moduleinstall \
+ --with-net=yes \
+ --with-udp=yes \
+ --with-sctp=no \
+ --with-stdio=yes \
+ --with-pty=yes \
+ --with-serialdev=yes \
+ --with-telnet=yes \
+ --without-tcl \
+ --without-openipmi \
+ --without-ipmisol \
+ --without-mdns \
+ --without-dnssd \
+ --without-alsa \
+ --without-winsound \
+ --without-portaudio \
+ --without-certauth \
+ --without-udev \
+ --without-ssl \
+ --enable-doc \
+ --disable-internal-trace \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}
diff --git a/net-misc/gensio/metadata.xml b/net-misc/gensio/metadata.xml
new file mode 100644
index 000000000000..846d0822488b
--- /dev/null
+++ b/net-misc/gensio/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ <name>Jason Zaman</name>
+ </maintainer>
+
+ <longdescription>
+ A library to abstract stream I/O like serial port, TCP, telnet, UDP, SSL, IPMI SOL, etc.
+ </longdescription>
+
+ <upstream>
+ <remote-id type="sourceforge">ser2net</remote-id>
+ <remote-id type="github">cminyard/gensio</remote-id>
+ </upstream>
+</pkgmetadata>