summaryrefslogtreecommitdiff
path: root/net-misc/gallery-dl/gallery-dl-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/gallery-dl/gallery-dl-9999.ebuild')
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
index fec914ad2ced..79c29ccc0450 100644
--- a/net-misc/gallery-dl/gallery-dl-9999.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=(python3_{8,9})
PYTHON_REQ_USE="sqlite,ssl,xml"
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 optfeature
@@ -29,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {