summaryrefslogtreecommitdiff
path: root/net-misc/ethflop/files
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ethflop/files')
-rw-r--r--net-misc/ethflop/files/ethflop-20191003-makefile.patch13
-rw-r--r--net-misc/ethflop/files/ethflopd.confd8
-rw-r--r--net-misc/ethflop/files/ethflopd.initd11
-rw-r--r--net-misc/ethflop/files/ethflopd.service10
4 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/ethflop/files/ethflop-20191003-makefile.patch b/net-misc/ethflop/files/ethflop-20191003-makefile.patch
new file mode 100644
index 000000000000..7005dfdbb44b
--- /dev/null
+++ b/net-misc/ethflop/files/ethflop-20191003-makefile.patch
@@ -0,0 +1,13 @@
+--- a/Makefile 2019-10-03 23:02:15.000000000 +0200
++++ b/Makefile 2019-10-15 08:31:49.541999473 +0200
+@@ -14,8 +14,8 @@
+ #CFLAGS = -O2 -Wall -std=gnu89 -pedantic -Wextra -Wformat-security -D_FORTIFY_SOURCE=1 -Weverything -Wno-padded
+
+ # production
+-CC = gcc
+-CFLAGS = -O2 -std=gnu89
++CC ?= gcc
++CFLAGS ?= -O2 -std=gnu89
+
+ all: ethflopd
+
diff --git a/net-misc/ethflop/files/ethflopd.confd b/net-misc/ethflop/files/ethflopd.confd
new file mode 100644
index 000000000000..a727dae4c726
--- /dev/null
+++ b/net-misc/ethflop/files/ethflopd.confd
@@ -0,0 +1,8 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Network interface, which should be used for serving floppy images
+INTERFACE="lo"
+
+# Storage directory, from where floppy images are being served
+STORAGEDIR="/tmp"
diff --git a/net-misc/ethflop/files/ethflopd.initd b/net-misc/ethflop/files/ethflopd.initd
new file mode 100644
index 000000000000..d00c63f980ae
--- /dev/null
+++ b/net-misc/ethflop/files/ethflopd.initd
@@ -0,0 +1,11 @@
+#!/sbin/openrc-run
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="ethflopd daemon"
+command="/usr/bin/ethflopd"
+command_args="${INTERFACE} ${STORAGEDIR}"
+
+depend() {
+ need net
+}
diff --git a/net-misc/ethflop/files/ethflopd.service b/net-misc/ethflop/files/ethflopd.service
new file mode 100644
index 000000000000..2b6c31902ec6
--- /dev/null
+++ b/net-misc/ethflop/files/ethflopd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=ethflopd daemon
+After=network-online.target
+
+[Service]
+EnvironmentFile=/etc/conf.d/ethflopd
+ExecStart=/usr/bin/ethflopd ${INTERFACE} ${STORAGEDIR}
+
+[Install]
+WantedBy=multi-user.target