summaryrefslogtreecommitdiff
path: root/net-misc/ethertypes/ethertypes-0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ethertypes/ethertypes-0.ebuild')
-rw-r--r--net-misc/ethertypes/ethertypes-0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/net-misc/ethertypes/ethertypes-0.ebuild b/net-misc/ethertypes/ethertypes-0.ebuild
new file mode 100644
index 000000000000..f292f7e125b0
--- /dev/null
+++ b/net-misc/ethertypes/ethertypes-0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Maps ethernet frame ids to symbolic names"
+HOMEPAGE="https://netfilter.org/"
+# File extracted from the iptables tarball
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND="
+ !<net-firewall/ebtables-2.0.10.4-r2
+ !<net-firewall/iptables-1.6.2-r2[nftables(-)]
+"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto /etc
+ newins "${P}" ethertypes
+}