summaryrefslogtreecommitdiff
path: root/net-misc/ena-driver/ena-driver-2.8.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ena-driver/ena-driver-2.8.8.ebuild')
-rw-r--r--net-misc/ena-driver/ena-driver-2.8.8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/ena-driver/ena-driver-2.8.8.ebuild b/net-misc/ena-driver/ena-driver-2.8.8.ebuild
new file mode 100644
index 000000000000..32810ec269da
--- /dev/null
+++ b/net-misc/ena-driver/ena-driver-2.8.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
+HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
+SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.tar.gz -> ${P}-linux.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"
+
+CONFIG_CHECK="PCI_MSI !CPU_BIG_ENDIAN DIMLIB"
+DOCS=(
+ README.rst
+ RELEASENOTES.md
+)
+
+src_compile() {
+ local modlist=( ena=net )
+ local modargs=( BUILD_PARAMS="CONFIG_MODULE_SIG=n KERNEL_DIR=${KV_DIR}" )
+ linux-mod-r1_src_compile
+}