summaryrefslogtreecommitdiff
path: root/net-misc/ena-driver/ena-driver-2.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ena-driver/ena-driver-2.8.2.ebuild')
-rw-r--r--net-misc/ena-driver/ena-driver-2.8.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/ena-driver/ena-driver-2.8.2.ebuild b/net-misc/ena-driver/ena-driver-2.8.2.ebuild
new file mode 100644
index 000000000000..21df1541893f
--- /dev/null
+++ b/net-misc/ena-driver/ena-driver-2.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info linux-mod
+
+DESCRIPTION="Amazon EC2 Elastic Network Adapter (ENA) kernel driver"
+HOMEPAGE="https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/enhanced-networking-ena.html"
+SRC_URI="https://github.com/amzn/amzn-drivers/archive/ena_linux_${PV}.tar.gz -> ${P}-linux.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}/amzn-drivers-ena_linux_${PV}/kernel/linux/ena"
+
+MODULE_NAMES="ena(net:${S}:${S})"
+BUILD_TARGETS="all"
+
+CONFIG_CHECK="PCI_MSI !CPU_BIG_ENDIAN DIMLIB"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CONFIG_MODULE_SIG=n KERNEL_DIR=${KV_DIR}"
+}
+
+src_prepare() {
+ default
+
+ sed -i -e 's!/lib/modules/\$(BUILD_KERNEL)/build!$(KERNEL_DIR)!g' \
+ "Makefile" || die "Unable to fix Makefile"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README.rst RELEASENOTES.md
+}