summaryrefslogtreecommitdiff
path: root/net-misc/dropbox-cli/dropbox-cli-2024.01.22.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dropbox-cli/dropbox-cli-2024.01.22.ebuild')
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-2024.01.22.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/dropbox-cli-2024.01.22.ebuild b/net-misc/dropbox-cli/dropbox-cli-2024.01.22.ebuild
new file mode 100644
index 000000000000..d2c3eb6fe937
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-2024.01.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="https://www.dropbox.com/"
+# https://linux.dropbox.com/packages/dropbox.py
+# https://www.dropbox.com/download?dl=packages/dropbox.py
+# https://raw.githubusercontent.com/dropbox/nautilus-dropbox/master/dropbox.in
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.py.xz"
+S=${WORKDIR}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gpg"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ gpg? ( app-crypt/gpgme[python] )
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${PN}-19-completion ${PN}
+}