summaryrefslogtreecommitdiff
path: root/net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild')
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild b/net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..b2dd3a01d442
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="http://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
+}