summaryrefslogtreecommitdiff
path: root/net-misc/dhcp/dhcp-4.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dhcp/dhcp-4.4.1.ebuild')
-rw-r--r--net-misc/dhcp/dhcp-4.4.1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-misc/dhcp/dhcp-4.4.1.ebuild b/net-misc/dhcp/dhcp-4.4.1.ebuild
index b092a1229505..140b6f709966 100644
--- a/net-misc/dhcp/dhcp-4.4.1.ebuild
+++ b/net-misc/dhcp/dhcp-4.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,7 +17,7 @@ SRC_URI="ftp://ftp.isc.org/isc/dhcp/${MY_P}.tar.gz
LICENSE="MPL-2.0 BSD SSLeay GPL-2" # GPL-2 only for init script
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="alpha ~amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="+client ipv6 kernel_linux ldap libressl selinux +server ssl vim-syntax"
DEPEND="
@@ -170,7 +170,7 @@ src_configure() {
cd bind/bind-*/ || die
local el
eval econf \
- $(for el in $(awk '/^bindconfig/,/^$/ {print}' ../Makefile.in) ; do if [[ ${el} =~ ^-- ]] ; then printf ' %s' ${el}; fi; done | sed 's,@\([[:alpha:]]\+\)dir@,${binddir}/\1,g') \
+ $(for el in $(awk '/^bindconfig/,/^$/ {print}' ../Makefile.in) ; do if [[ ${el} =~ ^-- ]] ; then printf ' %s' ${el} ; fi ; done | sed 's,@\([[:alpha:]]\+\)dir@,${binddir}/\1,g') \
--disable-symtable \
--without-make-clean
}
@@ -192,7 +192,7 @@ src_install() {
if [[ -e client/dhclient ]] ; then
# move the client to /
dodir /sbin
- mv "${D}"/usr/sbin/dhclient "${D}"/sbin/ || die
+ mv "${ED%/}"/usr/sbin/dhclient "${ED%/}"/sbin/ || die
exeinto /sbin
if use kernel_linux ; then
@@ -224,15 +224,15 @@ src_install() {
systemd_install_serviced "${FILESDIR}"/dhcrelay4.service.conf
systemd_install_serviced "${FILESDIR}"/dhcrelay6.service.conf
- sed -i "s:#@slapd@:$(usex ldap slapd ''):" "${ED}"/etc/init.d/* || die #442560
+ sed -i "s:#@slapd@:$(usex ldap slapd ''):" "${ED%/}"/etc/init.d/* || die #442560
fi
# the default config files aren't terribly useful #384087
local f
- for f in "${ED}"/etc/dhcp/*.conf.example ; do
+ for f in "${ED%/}"/etc/dhcp/*.conf.example ; do
mv "${f}" "${f%.example}" || die
done
- sed -i '/^[^#]/s:^:#:' "${ED}"/etc/dhcp/*.conf || die
+ sed -i '/^[^#]/s:^:#:' "${ED%/}"/etc/dhcp/*.conf || die
}
pkg_preinst() {
@@ -245,10 +245,10 @@ pkg_preinst() {
for f in dhclient:da7c8496a96452190aecf9afceef4510 dhcpd:10979e7b71134bd7f04d2a60bd58f070 ; do
h=${f#*:}
f="/etc/dhcp/${f%:*}.conf"
- if [ -e "${EROOT}"${f} ] ; then
+ if [ -e "${EROOT%/}"${f} ] ; then
case $(md5sum "${EROOT}"${f}) in
${h}*) ;;
- *) cp -p "${EROOT}"${f} "${ED}"${f};;
+ *) cp -p "${EROOT%/}"${f} "${ED%/}"${f};;
esac
fi
done