summaryrefslogtreecommitdiff
path: root/net-misc/dhcdrop/dhcdrop-0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/dhcdrop/dhcdrop-0.5.ebuild')
-rw-r--r--net-misc/dhcdrop/dhcdrop-0.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/dhcdrop/dhcdrop-0.5.ebuild b/net-misc/dhcdrop/dhcdrop-0.5.ebuild
new file mode 100644
index 000000000000..db32686b5063
--- /dev/null
+++ b/net-misc/dhcdrop/dhcdrop-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Effectively suppresses illegal DHCP servers on the LAN"
+HOMEPAGE="http://www.netpatch.ru/dhcdrop.html"
+SRC_URI="http://www.netpatch.ru/projects/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+IUSE="static"
+
+RDEPEND="!static? ( net-libs/libpcap )"
+DEPEND="static? ( net-libs/libpcap[static-libs] )
+ ${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf $(use static && echo "--enable-static-build")
+}