summaryrefslogtreecommitdiff
path: root/net-misc/curl/curl-8.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/curl/curl-8.2.1.ebuild')
-rw-r--r--net-misc/curl/curl-8.2.1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/net-misc/curl/curl-8.2.1.ebuild b/net-misc/curl/curl-8.2.1.ebuild
index b2ec02b6d7e6..72c9069bc754 100644
--- a/net-misc/curl/curl-8.2.1.ebuild
+++ b/net-misc/curl/curl-8.2.1.ebuild
@@ -30,6 +30,7 @@ RESTRICT="!test? ( test )"
# Only one default ssl provider can be enabled
# The default ssl provider needs its USE satisfied
+# nghttp3 = https://bugs.gentoo.org/912029
REQUIRED_USE="
ssl? (
^^ (
@@ -45,19 +46,20 @@ REQUIRED_USE="
curl_ssl_nss? ( nss )
curl_ssl_openssl? ( openssl )
curl_ssl_rustls? ( rustls )
+ nghttp3? ( !openssl )
"
RDEPEND="
sys-libs/zlib[${MULTILIB_USEDEP}]
adns? ( net-dns/c-ares:=[${MULTILIB_USEDEP}] )
brotli? ( app-arch/brotli:=[${MULTILIB_USEDEP}] )
- http2? ( >=net-libs/nghttp2-1.15.0:=[${MULTILIB_USEDEP}] )
+ http2? ( >=net-libs/nghttp2-1.12.0:=[${MULTILIB_USEDEP}] )
idn? ( net-dns/libidn2:=[static-libs?,${MULTILIB_USEDEP}] )
kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
ldap? ( net-nds/openldap:=[static-libs?,${MULTILIB_USEDEP}] )
nghttp3? (
- net-libs/nghttp3[${MULTILIB_USEDEP}]
- net-libs/ngtcp2[ssl,${MULTILIB_USEDEP}]
+ >=net-libs/nghttp3-0.13.0[${MULTILIB_USEDEP}]
+ >=net-libs/ngtcp2-0.17.0[gnutls,ssl,-openssl,${MULTILIB_USEDEP}]
)
rtmp? ( media-video/rtmpdump[${MULTILIB_USEDEP}] )
ssh? ( net-libs/libssh2[${MULTILIB_USEDEP}] )
@@ -85,6 +87,7 @@ RDEPEND="
)
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )
"
+
DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl