summaryrefslogtreecommitdiff
path: root/net-misc/curl/curl-7.86.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/curl/curl-7.86.0-r3.ebuild')
-rw-r--r--net-misc/curl/curl-7.86.0-r3.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/net-misc/curl/curl-7.86.0-r3.ebuild b/net-misc/curl/curl-7.86.0-r3.ebuild
index 50c94270b54b..fb34199c73a2 100644
--- a/net-misc/curl/curl-7.86.0-r3.ebuild
+++ b/net-misc/curl/curl-7.86.0-r3.ebuild
@@ -13,8 +13,8 @@ SRC_URI="https://curl.haxx.se/download/${P}.tar.xz
LICENSE="curl"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap ipv6 kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp samba +smtp ssh ssl sslv3 static-libs test telnet +tftp websockets zstd"
-IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl"
+IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap ipv6 kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp rustls samba +smtp ssh ssl sslv3 static-libs test telnet +tftp websockets zstd"
+IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl curl_ssl_rustls"
IUSE+=" nghttp3 quiche"
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/danielstenberg.asc
@@ -26,6 +26,7 @@ REQUIRED_USE="
curl_ssl_mbedtls
curl_ssl_nss
curl_ssl_openssl
+ curl_ssl_rustls
)
)"
@@ -52,6 +53,9 @@ RDEPEND="ldap? ( net-nds/openldap:=[${MULTILIB_USEDEP}] )
dev-libs/nss-pem
app-misc/ca-certificates
)
+ rustls? (
+ net-libs/rustls-ffi:=[${MULTILIB_USEDEP}]
+ )
)
http2? ( net-libs/nghttp2:=[${MULTILIB_USEDEP}] )
nghttp3? (
@@ -116,7 +120,7 @@ multilib_src_configure() {
myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
#myconf+=( --without-default-ssl-backend )
if use ssl ; then
- myconf+=( --without-gnutls --without-mbedtls --without-nss )
+ myconf+=( --without-gnutls --without-mbedtls --without-nss --without-rustls )
if use gnutls || use curl_ssl_gnutls; then
einfo "SSL provided by gnutls"
@@ -134,6 +138,10 @@ multilib_src_configure() {
einfo "SSL provided by openssl"
myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
fi
+ if use rustls || use curl_ssl_rustls; then
+ einfo "SSL provided by rustls"
+ myconf+=( --with-rustls )
+ fi
if use curl_ssl_gnutls; then
einfo "Default SSL provided by gnutls"
@@ -147,6 +155,9 @@ multilib_src_configure() {
elif use curl_ssl_openssl; then
einfo "Default SSL provided by openssl"
myconf+=( --with-default-ssl-backend=openssl )
+ elif use curl_ssl_rustls; then
+ einfo "Default SSL provided by rustls"
+ myconf+=( --with-default-ssl-backend=rustls )
else
eerror "We can't be here because of REQUIRED_USE."
fi
@@ -224,7 +235,6 @@ multilib_src_configure() {
$(use_with nghttp3 ngtcp2)
$(use_with quiche)
$(use_with rtmp librtmp)
- --without-rustls
--without-schannel
--without-secure-transport
$(use_enable websockets)