summaryrefslogtreecommitdiff
path: root/net-misc/connman
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/Manifest1
-rw-r--r--net-misc/connman/connman-1.36-r1.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index 96dfd881b019..278d6e8886a6 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -9,5 +9,6 @@ AUX connman.service 198 BLAKE2B 8b943dc995fed630b15bcfe1040598e13a5b2118967f9fb6
DIST connman-1.35.tar.xz 686092 BLAKE2B 706d8333dc2fcbee8d0ef3849325c4975dfe312a7a542ee96859a1724e05b1302c244a0108ab70033b398301c235fb13cb9509e9147dc2bb049e900f3799cd98 SHA512 2234b4d18b038f9a33939035cddebd31c74ce962e5616c2c30b2912476612ef3f7d5b9edca64bf6e69fa358252ed432124e036ac3516b291b86695cb9a96c6a8
DIST connman-1.36.tar.xz 692616 BLAKE2B 7d8cea55365fbfe78cd897b5b65d8edf475a737220732c46c95dda4c6b12badddca38150dbedddcc95c29bce486d86fe130a9d65043c6e18ed6b1eba3fe5aec0 SHA512 c0b9e924a28d58539d44c314168ae7aa46dfea8ce9d125198f525a6d6ef95ca77fd0357c4c4c7548b362b9de8e6f85c7915b1a4cf89b65116c4cbc4df75318e1
EBUILD connman-1.35-r1.ebuild 2555 BLAKE2B 7369ceafa9bd072bd8020da45453bd07ddacb10606bb3d61ceddfd3367b15bdbf890a00aa579536d548b52fd6c6656d79cdb31d290d2ac6301a6f04ffbd0724d SHA512 640be0029a8c6568a47973743f968cc641a579523f4288cc5ac0347b72721f547f608729c2865b2a31e15394e2c85a18b360936e082ac3f7069296e9977870b8
+EBUILD connman-1.36-r1.ebuild 2587 BLAKE2B ed3365fca807716a3e51e4ec9dc6b24baa144bd9f48d72e5d68b30a512663e9ba0d3497d1f8532a3b3d260d546df37f489b1c7fdb7f1d70931bd3043a9a881ea SHA512 4ba0e07568052cea00aeb6ccb8dbccc4e339712ddbb8c2b22716659298afd09863de1a2b3f1f3325b0ff40e24d8345fe1fc408085874a8ee5897be861df3bfdd
EBUILD connman-1.36.ebuild 2568 BLAKE2B 902e767beeeb20850f0387485444905ac4b607dbdcca5fe73b4db808df7534829d2a2ccec1636c1ecaf8cbcc0c60bea9dc8b8865d8da13b1d748fd778a62d551 SHA512 f9c93a7263ce7d683dcfb6e1fc2d6798a222159bdcaf432ab75fb37d5c8a37e200ad6ad2ba5efef8438eff2eaa486545d4593817aa9ff3532833c1a15f9acb27
MISC metadata.xml 1158 BLAKE2B 57d083417dd0b186b1d45368f1ffab64d6283535ae6f25adfd6cd85d26f535544f0b89d7f731dbb876ba7acd1973abdd26ac7643c050adc9a433d321ffc9fb57 SHA512 2d272d638d9f9f06eb900736815eb0e401520f3ad86082beea541932626c5758e220f692931772ecafffbd60798f0df38e8c9e8a02b58c03743ed984955edb8b
diff --git a/net-misc/connman/connman-1.36-r1.ebuild b/net-misc/connman/connman-1.36-r1.ebuild
new file mode 100644
index 000000000000..376b73082b7a
--- /dev/null
+++ b/net-misc/connman/connman-1.36-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit autotools systemd tmpfiles
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://01.org/connman"
+SRC_URI="mirror://kernel/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+IUSE="${IUSE} bluetooth debug doc examples +ethernet iptables iwd l2tp nftables"
+IUSE="${IUSE} ofono openvpn openconnect pptp policykit tools vpnc +wifi wispr networkmanager"
+
+REQUIRED_USE="|| ( iptables nftables )"
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.2.24
+ sys-libs/readline:0=
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ bluetooth? ( net-wireless/bluez )
+ iwd? ( net-wireless/iwd )
+ l2tp? ( net-dialup/xl2tpd )
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0= )
+ ofono? ( net-misc/ofono )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ policykit? ( sys-auth/polkit )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wifi? ( >=net-wireless/wpa_supplicant-2.0[dbus] )
+ wispr? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.39
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.33-polkit-configure-check-fix.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable examples test) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable wifi wifi builtin) \
+ $(use_enable iwd) \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wispr wispr builtin) \
+ $(use_enable debug) \
+ $(use_enable tools) \
+ $(use_enable networkmanager nmcompat) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/connman_resolvconf.conf
+}